数值分解--递归

数值分解

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

对一个自然数N ( 1 <= N <= 50 ) ,N可以分解成若干个数字(数字可以是1,2,3,….,9)之和,问题是如何分解能使这些数字的乘积最大。

Input

输入数据有多组,每组占一行,每行包含一个自然数N(1 <= N <= 50)。输入文件直到EOF为止!

Output

对每组输入,输出有2行。第一行是N分解出的所有数字,以空格分隔,最后一个数字后也有空格;第二行是N分解出的所有数字的个数、乘积。

Sample Input

20
24
28

Sample Output

3 3 3 3 3 3 2
7 1458
3 3 3 3 3 3 3 3
8 6561 
3 3 3 3 3 3 3 3 4
9 26244

Hint

由数学知识可知,只有把N分成尽可能多的3,它们的乘积才能最大(当只剩下4时不用再分,因为: 4 > 3*1)

代码如下:

#include <stdio.h>
#include <stdlib.h>
int  sum, mut;
void f(n)
{
    while(n > 4)
    {
        printf("3 ");
        n -= 3;
        sum++;
        mut *= 3;
    }
    printf("%d ", n);
    sum++;
    mut *= n;
}
int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        sum = 0;
        mut = 1;
        f(n);
        printf("\n%d %d\n", sum, mut);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u011145745/article/details/81455542