poj1579 Function Run Fun 记忆化搜索

Function Run Fun

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

思路:

刚看想着公式都给了,就直接暴搜不好了嘛,所以也直接TLE,这一发T得很开心,所以还是要dp数组记录一下

代码:

#include<bits/stdc++.h>
using namespace std;
int dp[30][30][30];
int dfs(int a,int b,int c)
{
	int res;
	if (a <= 0 || b <= 0 || c <= 0)
		return 1;
	else if (a > 20 || b > 20 || c > 20)
		return 1048576;
	else if (dp[a][b][c])
		return dp[a][b][c];
	else if (a < b && b < c)
		res = dfs(a,b,c - 1) + dfs(a,b - 1,c - 1) - dfs(a,b - 1,c);
	else
		res =  dfs(a - 1,b,c) + dfs(a - 1,b - 1,c) + dfs(a - 1,b,c - 1) - dfs(a - 1,b - 1,c - 1);
	return dp[a][b][c] = res;
}
int main()
{
	int a,b,c;
	while (scanf("%d %d %d",&a,&b,&c) && (a != -1 || b != -1 || c != -1))
	{
		memset(dp,0,sizeof(dp));
		int ans = dfs(a,b,c);
		printf("w(%d, %d, %d) = %d\n",a,b,c,ans);	
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81571065