D - Function Run Fun

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1 
2 2 2 
10 4 6 
50 50 50 
-1 7 18 
-1 -1 -1

Sample Output

w(1, 1, 1) = 2 
w(2, 2, 2) = 4 
w(10, 4, 6) = 523 
w(50, 50, 50) = 1048576 
w(-1, 7, 18) = 1

用纯递归的思想会超时,用边搜索边记忆的思路 

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#define LL long long 
using namespace std;
int  aa[21]={1,2,4,},t=0;
int bb[21][21][21];
int quick_mod(int n,int k)  快速幂求次方
{
    int  sum=1;
    n%=k;
    while(k!=0)
    {
        if(k&1)
        {
            sum=sum*n;
        }
        n=n*n;
        k>>=1;
    }
    return sum;
}
int dj(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
    {
        return 1;
    }
    if(a>20||b>20||c>20)
    return dj(20,20,20);
    if(bb[a][b][c])         这很重要,没有这个,就是死循环
    return bb[a][b][c];
    if(a<b&&b<c)
    bb[a][b][c]=dj(a,b,c-1)+dj(a,b-1,c-1)-dj(a,b-1,c);
    else
    bb[a][b][c]=dj(a-1,b,c)+dj(a-1,b-1,c)+dj(a-1,b,c-1)-dj(a-1,b-1,c-1);   边搜索,边记忆
    return bb[a][b][c];
}
int main()
{
    int i,j,k,a,b,c;
    memset(bb,0,sizeof(bb));
    for(i=3;i<21;i++)
    {
        aa[i]=quick_mod(2,i);
    }
    
    while(~scanf("%d%d%d",&a,&b,&c))
    {
        if(a==-1&&b==-1&&c==-1)
        break;
        if(a==b&&b==c&&a<20)
        {
            printf("w(%d, %d, %d) = %d\n",a,b,c,aa[a]);
            continue;
        }
        if(a==b&&b==c&&a>20)
        {
            printf("w(%d, %d, %d) = %d\n",a,b,c,aa[20]);
            continue;
        }
        dj(a,b,c);
        printf("w(%d, %d, %d) = %d\n",a,b,c,dj(a,b,c));   我把这小写看成了大写。
    }
    return 0;
}
 

扫描二维码关注公众号,回复: 4126243 查看本文章

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/82083340
今日推荐