POJ 1984 Navigation Nightmare

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n):

           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 


Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17
...

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1".

Input

* Line 1: Two space-separated integers: N and M



* Lines 2..M+1: Each line contains four space-separated entities, F1,

        F2, L, and D that describe a road. F1 and F2 are numbers of

        two farms connected by a road, L is its length, and D is a

        character that is either 'N', 'E', 'S', or 'W' giving the

        direction of the road from F1 to F2.



* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

        queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

        and contains three space-separated integers: F1, F2, and I. F1

        and F2 are numbers of the two farms in the query and I is the

        index (1 <= I <= M) in the data after which Bob asks the

        query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

        queries.  Each line should contain either a distance

        measurement or -1, if it is impossible to determine the

        appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

题意:

按时间从1到M给出一些城市的连通情况, 然后求在某个时间两个城市是否联通, 如果联通, 则求出之间的距离, 如果不连通, 输出-1.

思路:

一开始冥思苦想没想出思路来, 然后去询问追风阿军,然后恍然大悟, 发现自己还是太蠢了。

先把给出的查询时间按从小到大的顺序排好序,然后再进行集合的合并操作,如果时间匹配则进行判定。

判定的方法只需要寻找他们的父节点是否一致, 如果不一致, 则说明两点不连通。

如果一致则求出两点与根节点的距离之差。

如何求两点的距离之差呢:

  1. 设一个数组d,这个数组表示的意思是到根节点的距离, 在查找操作中更新子节点到根节点的距离, 即h[x]=h[x的父节点]+h[x]
  2. 在合并操作中, 让一个父节点temp2指向另一个父节点temp1。 然后h[temp2]=d+h[x]-h[y]; 这个公式画个图就能推出来了。

     x表示temp1的子节点,y表示temp2的子节点。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=40005;
int a[maxn];
int n,m;
//存储查询操作的数据
struct inq
{
    int x,y,t;
    int no;
};
//存储节点之间关系的数据
struct que
{
    int x,y;
    int dis;
    char s[5];
};
inq in[maxn];
que q[maxn];
bool compare (inq a,inq b)
{
    return a.t<b.t;
}
//东西坐标和南北坐标
struct dis
{
    int x,y;
};
dis d[maxn];
//查找操作
int finds (int x)
{
    int temp=a[x];
    if(x==a[x])
        return x;
    int par=finds(a[x]);
    //关键
    d[x].x=d[x].x+d[temp].x;
    d[x].y=d[x].y+d[temp].y;
    //路径压缩
    a[x]=par;
    return par;
}
//存储最后结果的数组
int re[maxn];
//合并操作
int unite(int x,int y,int dd,char * s)
{
    int temp1=finds(x);
    int temp2=finds(y);
    if(temp1!=temp2)
    {
        a[temp2]=temp1;
        //关键
        if(s[0]=='E')
        {
            d[temp2].x=dd+d[x].x-d[y].x;
            d[temp2].y=0+d[x].y-d[y].y;
        }
        else if(s[0]=='W')
        {
            d[temp2].x=(-dd)+d[x].x-d[y].x;
            d[temp2].y=0+d[x].y-d[y].y;
        }
        else if(s[0]=='N')
        {
            d[temp2].y=dd+d[x].y-d[y].y;
            d[temp2].x=0+d[x].x-d[y].x;
        }
        else if(s[0]=='S')
        {
            d[temp2].y=(-dd)+d[x].y-d[y].y;
            d[temp2].x=0+d[x].x-d[y].x;
        }
    }
}
int main()
{
   scanf("%d%d",&n,&m);
   for (int i=1;i<=n;i++)
   {
       a[i]=i;
       d[i].x=0;
       d[i].y=0;
   }
   for (int i=0;i<m;i++)
   {
       scanf("%d %d %d %s",&q[i].x,&q[i].y,&q[i].dis,q[i].s);
   }
   int ci;
   scanf("%d",&ci);
   for (int i=0;i<ci;i++)
   {
       scanf("%d%d%d",&in[i].x,&in[i].y,&in[i].t);
       in[i].no=i;
   }
   sort (in,in+ci,compare);
   /*for (int i=0;i<ci;i++)
    printf("%d %d %d %d\n",in[i].x,in[i].y,in[i].t,in[i].no);*/
    int j=0;
   for (int i=0;i<m;i++)
   {
       unite(q[i].x,q[i].y,q[i].dis,q[i].s);
       if(j>ci)
         break;
       while(in[j].t-1==i)
       {
           int temp1=finds(in[j].x);
           int temp2=finds(in[j].y);
           if(temp1==temp2)
           {
               re[in[j].no]=(abs(d[in[j].x].x-d[in[j].y].x)+abs(d[in[j].x].y-d[in[j].y].y));
               //printf("%d\n",(abs(d[in[j].x].x-d[in[j].y].x)+abs(d[in[j].x].y-d[in[j].y].y)));
           }
           else
            {
               // printf("-1\n");
                re[in[j].no]=-1;
            }
          j++;
       }
   }
   for (int i=0;i<ci;i++)
       printf("%d\n",re[i]);
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81534951