Nightmare(bfs)

Nightmare

时间限制:1000 ms  |  内存限制:65535 KB

难度:4

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

输出

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

样例输入

2
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3

样例输出

4
-1

上传者

ACM_林志强

描述

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

题意:一个迷宫有一个炸弹,最初爆炸时间是6,必须在爆炸时间变成0之前走出迷宫,0是墙,1是路,2是起点,3是终点,4是炸弹爆炸时间重置为6,爆炸时间可以多次重置。注意若走到迷宫出口的爆炸时间为1,算不能走出;若走到4位置的爆炸时间为1则不能重置时间。若能走出迷宫输出最少的时间,否则输出-1。

思路:需要想清楚一点,虽然爆炸时间可以多次重置,但其实我们只需要重置一次就够了,因为广搜会把所有可行的走法放入队列中去搜索答案。所以我们只需重置一次时间即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<map>
#include<vector>
#include<stack>
#include<queue>
using namespace std;
#define LL long long
const int N=55;
int m,n,a[N][N],dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
struct node
{
    int x,y,time,step;
}now,net;
bool can(int x,int y)
{
    if(x<0||x>=m||y<0||y>=n||a[x][y]==0) return false;
    return true;
}
void bfs()
{
    queue<node>q;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            net=now;
            net.x+=dir[i][0];
            net.y+=dir[i][1];
            if(can(net.x,net.y))
            {
                net.time--;
                net.step++;
                if(net.time!=0)
                {
                    if(a[net.x][net.y]==3)
                    {
                        printf("%d\n",net.step);
                        return ;
                    }
                    if(a[net.x][net.y]==4)
                    {
                        net.time=6;
                        a[net.x][net.y]=1;
                    }
                    q.push(net);
                }
            }
        }
    }
    printf("-1\n");
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            {
                scanf("%d",&a[i][j]);
                if(a[i][j]==2)
                {
                    now.x=i,now.y=j;
                    now.step=0,now.time=6;
                }
            }
        bfs();
    }
}

另一种解法:设置一个数组存爆炸时间,每次与当前的爆炸时间相比较,若当前爆炸时间大于数组的爆炸时间,则放入队列,并修改数组的爆炸时间。

 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
const int N=10;
int mp[N][N];
int m,n,br[N][N];
struct node
{
    int x,y,t,step;
};
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
int bfs(int sx,int sy)
{
    memset(br,0,sizeof(br));
    node h;
    h.x=sx,h.y=sy,h.t=6,h.step=0;
    br[h.x][h.y]=6;
    queue<node>q; 
    while(!q.empty()) q.pop();
    q.push(h);
    while(!q.empty())
    {
        h=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            node nx;
            nx.t=h.t-1;
            nx.x=h.x+dx[i];
            nx.y=h.y+dy[i];
            nx.step=h.step+1;
            if(nx.x>=1&&nx.y>=1&&nx.x<=n&&nx.y<=m)
            {
                if(mp[nx.x][nx.y]==4)
                {
                    if(6>br[nx.x][nx.y])
                    {
                        nx.t=6;
                        q.push(nx);
                        br[nx.x][nx.y]=6;
                    }
                }
                else if(mp[nx.x][nx.y]==1)
                {
                    if(nx.t==1) continue;
                    if(br[nx.x][nx.y]<nx.t)
                    {
                        q.push(nx);
                        br[nx.x][nx.y]=nx.t;
                    }
                }
                else if(mp[nx.x][nx.y]==3)
                    return nx.step;
            }
        }
    }
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int sx,sy;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=m;++j)
            {
                scanf("%d",&mp[i][j]);
                if(mp[i][j]==2)
                    sx=i,sy=j;
            }
        }
        cout<<bfs(sx,sy)<<endl;
    }
    return 0;
}        

猜你喜欢

转载自blog.csdn.net/never__give__up/article/details/81085484