数据结构实验之链表七:单链表中重复元素的删除(坑题)

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Sample Input

10
21 30 14 55 32 63 11 30 55 30

Sample Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint

Source

不得使用数组!

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    node *next;
};
int main()
{
    int n;
    cin>>n;
    node *head = new node;
    head->next = NULL;
    for(int i =0;i<n;i++)
    {
        node *p = new node;
        p->next=NULL;
        cin>>p->data;
        p->next = head->next;
        head->next = p;
    }
    cout<<n<<endl;
    node *tail = new node;
    for(tail = head->next;tail!=NULL;tail = tail->next)//我很纳闷为啥终止条件写成tail->next!=NULL就Runtime Error了
    {
        if(tail->next==NULL)
        {
            cout<<tail->data<<endl;
        }else
        {
            cout<<tail->data<<" ";
        }
    }
    node *p = new node;
    node *q = new node;
    for(p = head->next;p!=NULL;p = p->next)
    {
        node *t = p;
        for(q = p->next;q!=NULL;q = q->next)
        {
            if(q->data==p->data)
            {
                t->next = q->next;
                n--;
            }else
            {
                t = t->next;
            }
        }
    }
    cout<<n<<endl;
    for(tail = head->next;tail !=NULL;tail = tail->next)
    {
        if(tail->next == NULL)
        {
            cout<<tail->data<<endl;
        }else
        {
            cout<<tail->data<<" ";
        }
    }
    return 0;
}
发布了99 篇原创文章 · 获赞 21 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_43721423/article/details/102515910