2122数据结构实验之链表七:单链表中重复元素的删除

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Sample Input

10
21 30 14 55 32 63 11 30 55 30

Sample Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint

Source

不得使用数组!


#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node*next;
};
struct node*create(int n)
{
    int i;
  struct node*head,*p;
  head=(struct node*)malloc(sizeof(struct node));
  head->next=NULL;
  for(i=1;i<=n;i++)
  {
      int t;
      scanf("%d",&t);
      p=(struct node*)malloc(sizeof(struct node));
      p->next=NULL;
      p->data=t;
      p->next=head->next;
      head->next=p;
  }
  return head;
}
void print(struct node*head)
{
    struct node*p;
    p=head->next;
    while(p!=NULL)
    {
        if(p==head->next)
        printf("%d",p->data);
        else printf(" %d",p->data);
        p=p->next;
    }
    printf("\n");
}
void dele(struct node*head,int n)
{
    struct node*p,*q,*r;
    p=head->next;
    q=p;
    while(p!=NULL)
    {
        q=p;
        r=q->next;
        while(r!=NULL)
        {
            if(r->data==p->data)
            {
                q->next=r->next;
                n--;
            }
            else q=r;
            r=r->next;
        }
        p=p->next;
    }
    printf("%d\n",n);
    print(head);
}
int main()
{
    int n;
    scanf("%d",&n);
    struct node*head;
    head=create(n);
    printf("%d\n",n);
    print(head);
    dele(head,n);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81460355