A Sweet Journey

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

Input

In the first line there is an integer t (1≤t≤501≤t≤50), indicating the number of test cases. 
For each test case: 
The first line contains four integers, n, A, B, L. 
Next n lines, each line contains two integers: Li,RiLi,Ri, which represents the interval [Li,Ri][Li,Ri] is swamp. 
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L. 
Make sure intervals are not overlapped which means Ri<Li+1Ri<Li+1 for each i (1≤i<n1≤i<n).
Others are all flats except the swamps. 

Output

For each text case: 
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning. 

Sample Input

1
2 2 2 5
1 2
3 4

Sample Output

Case #1: 0

#include <cstdio>
#define maxn 100
struct st{
    int x,y;
}mvp[maxn];
int main()
{
    int t,j=0;
    scanf("%d",&t);
    while(t--)
    {
        j++;
        int n,a,b,l;
        scanf("%d%d%d%d",&n,&a,&b,&l);
        for(int i=0;i<n;i++)
            scanf("%d%d",&mvp[i].x,&mvp[i].y);
        int m,c,ans;
        m=mvp[0].x*b;
        c=0;
        ans=0;
        for(int i=0;i<n;i++)
        {
            c=c+m;
            if(c<(mvp[i].y-mvp[i].x)*a)
            {
                ans=ans+(mvp[i].y-mvp[i].x)*a-c;
                c=0;
            }
            else
                c=c-(mvp[i].y-mvp[i].x)*a;
            m=(mvp[i+1].x-mvp[i].y)*b;
        }
        printf("Case #%d: %d\n",j,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/unikue/article/details/81304509