2015 ACM/ICPC Asia Regional Shanghai Online J - A Sweet Journey

J - A Sweet Journey

 

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

InputIn the first line there is an integer t ( 1t501≤t≤50), indicating the number of test cases. 
For each test case: 
The first line contains four integers, n, A, B, L. 
Next n lines, each line contains two integers:  Li,RiLi,Ri, which represents the interval  [Li,Ri][Li,Ri] is swamp. 
1n100,1L105,1A10,1B101Li<RiL1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L
Make sure intervals are not overlapped which means  Ri<Li+1Ri<Li+1 for each i ( 1i<n1≤i<n). 
Others are all flats except the swamps. 
OutputFor each text case: 
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning. 
Sample Input
1
2 2 2 5
1 2
3 4
Sample Output
Case #1: 0

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n,a,b,l;
struct node
{
    int l,r;
}p[105];
bool cmp(node x,node y)
{
    return x.l<y.l;
}
int main()
{
    int m;
    cin>>m;
    int cnt=1;
    while(m--)
    {
        cin>>n>>a>>b>>l;
        for(int i=1;i<=n;i++)
        {
            cin>>p[i].l>>p[i].r;
        }
        sort(p+1,p+n+1,cmp);//以防沼泽输入时,顺序不对
        int e=0,sum=0,res=0;
        for(int i=1;i<=n;i++)
        {
            sum+=(p[i].l-e)*b;
            int num=p[i].r-p[i].l;
            if(sum/a>=num)
            {
                sum-=num*a;
            }
            else
            {
                res+=num*a-sum;
                sum=0;
            }
            e=p[i].r;
        }
        printf("Case #%d: %d\n",cnt++,res);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80960307
今日推荐