I - A Sweet Journey

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

Input

In the first line there is an integer t (1≤t≤501≤t≤50), indicating the number of test cases. 
For each test case: 
The first line contains four integers, n, A, B, L. 
Next n lines, each line contains two integers: Li,RiLi,Ri, which represents the interval [Li,Ri][Li,Ri] is swamp. 
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L. 
Make sure intervals are not overlapped which means Ri<Li+1Ri<Li+1 for each i (1≤i<n1≤i<n).
Others are all flats except the swamps. 

Output

For each text case: 
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning. 

Sample Input

1
2 2 2 5
1 2
3 4

Sample Output

Case #1: 0

cin 超时改成scanf AC

#include<bits/stdc++.h>
using namespace std;
int d[100005];
int main()
{
	int n,a,b,l,p,q;
	int t;
	cin>>t;
	for(int k=1;k<=t;k++)
	{
		scanf("%d%d%d%d",&n,&a,&b,&l);
		for(int i=0;i<l;i++)
			d[i]=b;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&p,&q);
			for(int j=p;j<q;j++)
				d[j]=-a;
		}
		int sum=0;
		int ans=0;
		for(int i=0;i<l;i++)
		{
			sum+=d[i];
			if(sum<0)
			{
				ans+=abs(sum);
				sum=0;
			}
			
		}
		printf("Case #%d: %d\n",k,ans);
	}	
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81383713