2018 Multi-University Training Contest 3 D( Euler Function)

Problem Description
In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1 itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.
 

Input
The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109).
 

Output
For each test case, print a single line containing an integer, denoting the answer.
 

Sample Input
2
1
2
 

Sample Output
5
7

题意:给定 k,求第 k 小的数 n,满足 φ(n) 是合数。显然 φ(1) = 1 不是合数,只考虑 n ≥ 2 的情况。

思路:φ(n)=n*(1-1/p1)*(1-1/p2)*(1-1/p3)*(1-1/p4)…..(1-1/pn),其实看到欧拉函数公式就已经非常清楚了。从5开始的所有欧拉函数都符合条件,实在不行把欧拉函数打表出来就看出来了。

代码:

#include <bits/stdc++.h>
using namespace std; 
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        if(n==1)
        cout<<5<<endl;
        else if(n==2) cout<<7<<endl;
        else
        {
            cout<<n+5<<endl;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/snayf/article/details/81319921