2018 Multi-University Training Contest 3 Problem D. Euler Function

原题:http://acm.hdu.edu.cn/contests/contest_showproblem.php?pid=1004&cid=804
 

Problem Description

In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.

Input

The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109).

Output

For each test case, print a single line containing an integer, denoting the answer.

Sample Input

2 1 2

Sample Output

5 7

分析:欧拉函数,很容噢乖难以手动推出1,2,3,4,6的欧拉值都是素数,其余的都是合数。

#include<bits/stdc++.h>
using namespace std;
int t, n;

int main(){
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        if(n == 1) printf("5\n");
        else printf("%d\n", n+5);
    }
}

 

猜你喜欢

转载自blog.csdn.net/m0_37611893/article/details/81292010
今日推荐