hdu1263 fruit

题目链接https://vjudge.net/contest/235899#problem/C

题目如下

夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.

Input

第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.

Output

对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行.

Sample Input

1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1

Sample Output

guangdong
   |----pineapple(5)
   |----sugarcane(1)
shandong
   |----apple(3)

这道题可以利用map的二维应用,即map映射map

做这道题时还意外了解到,cout的endl有换行的功能

代码如下

#include<cstdio>
#include<iostream>
#include<map>
#include<string>
#include<algorithm>
using namespace std;
map<string,map<string,int>>mp;
int n,m;
string fruit,place;
int num;
int main()
{
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>m;
		mp.clear();//注意,每组数据重新开始
		for(int j=0;j<m;j++)
		{
			cin>>fruit>>place>>num;
			mp[place][fruit]+=num;
		}
		for(map<string,map<string,int>>::iterator a=mp.begin();a!=mp.end();a++)
		{
			cout<<a->first<<endl;
			for(map<string,int>::iterator b=a->second.begin();b!=a->second.end();b++)
			{
				cout<<"   |----"<<b->first<<"("<<b->second<<")"<<endl;
			}
		}
		if(i!=n-1)printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41626975/article/details/81483648