Hdu1263 水果

      夏天来了~~好开心啊,呵呵,好多好多水果~~ 
      Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了. 
Input
第一行正整数N(0<N<=10)表示有N组测试数据. 
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成. 
Output
对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序. 
两组测试数据之间有一个空行.最后一组测试数据之后没有空行. 
Sample Input
1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1
Sample Output
guangdong
   |----pineapple(5)
   |----sugarcane(1)
shandong
   |----apple(3)

题解:map的嵌套,输出格式好麻烦。

#include<cstdio>
#include<map>
#include<string>
#include<iostream>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n,i,amount;
        string place,fruit;
        map<string,map<string,int> >m;
        map<string,map<string,int> >::iterator t1;
        map<string,int> ::iterator t2;
        scanf("%d",&n);
        for (i=0;i<=n-1;i++)
        {
           cin>>fruit>>place>>amount;
           m[place][fruit]+=amount;
        }
        for (t1=m.begin();t1!=m.end();t1++)
        {
            cout<<t1->first<<endl;
            for (t2=t1->second.begin();t2!=t1->second.end();t2++)
            cout<<"   |----"<<t2->first<<"("<<t2->second<<")"<<endl;
        }
        if (t!=0) cout<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/parkerljc/article/details/81067860