2018 Multi-University Training Contest 5 1005 Everything Has Changed

Everything Has Changed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 793    Accepted Submission(s): 466
Special Judge

 

Problem Description

Edward is a worker for Aluminum Cyclic Machinery. His work is operating mechanical arms to cut out designed models. Here is a brief introduction of his work.
Assume the operating plane as a two-dimensional coordinate system. At first, there is a disc with center coordinates (0,0) and radius R. Then, m mechanical arms will cut and erase everything within its area of influence simultaneously, the i-th area of which is a circle with center coordinates (xi,yi) and radius ri (i=1,2,⋯,m). In order to obtain considerable models, it is guaranteed that every two cutting areas have no intersection and no cutting area contains the whole disc.
Your task is to determine the perimeter of the remaining area of the disc excluding internal perimeter.
Here is an illustration of the sample, in which the red curve is counted but the green curve is not.

 

Input

The first line contains one integer T, indicating the number of test cases.
The following lines describe all the test cases. For each test case:
The first line contains two integers m and R.
The i-th line of the following m lines contains three integers xi,yi and ri, indicating a cutting area.
1≤T≤1000, 1≤m≤100, −1000≤xi,yi≤1000, 1≤R,ri≤1000 (i=1,2,⋯,m).

 

Output

For each test case, print the perimeter of the remaining area in one line. Your answer is considered correct if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a and the jury's answer be b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.

 

Sample Input

 

1 4 10 6 3 5 10 -4 3 -2 -4 4 0 9 1

 

Sample Output

 

81.62198908430238475376

 

Source

2018 Multi-University Training Contest 5

题意:给你一个半径为R的圆,随机在圆上进行切割,问切割完后的周长是多少;

思路:模拟即可;

下面附上我的代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<string>
#define LL long long
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define lson o<<1
#define rson o<<1|1
using namespace std;
double Cal_dis(double x1, double y1)
{
	return sqrt(x1 * x1 + y1 * y1);
}
int main()
{
	int T, m;
	double R;
	cin >> T;
	while(T--)
	{
		scanf("%d %lf", &m, &R);
		double sum = 2 * PI * R;
		double x, y, r;
		for(int i = 0; i < m; i++)
		{
			scanf("%lf %lf %lf", &x, &y, &r);
			double p = Cal_dis(x, y);
			if((p > R && p < R + r) ||(p < R && p + r > R))
			{
				double th1 = acos((R * R + p * p - r * r) / (2 * R * p));
				sum -= 2 * th1 * R;
				double th2 = acos((r * r + p * p - R * R) / (2 * r * p));
				sum += 2 * th2 * r;
			}
			else if(p < R && p + r == R)
				sum += 2 * PI * r;
		}
		printf("%.20lf\n", sum);
	}
    return 0;	
}

猜你喜欢

转载自blog.csdn.net/gtuif/article/details/81489720
今日推荐