POJ 3122 Pie

Pie

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22950   Accepted: 7187   Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

二分题,第一个要注意,分Pie的人是f + 1,包括自己,然后就是每个人分的Pie是一块,不是简单的求平均题,

下界low=0,即每人都分不到pie

上界high=maxsize,每人都得到整个pie,而且那个pie为所有pie中最大的

                   (上界就是 n个人n个pie,每个pie还等大)

对当前上下界折中为mid,计算"如果按照mid的尺寸分pie,能分给多少人"

由于每个pie都是圆的,为了保证精度和减少运算,我的程序在计算过程中把 π 先忽略,仅仅用半径R²去计算,最后的结果再乘π

代码如下:

#include<iostream>
#include<stdio.h>
#include<algorithm>
const double PI = 3.14159265359;
const double eps = 1e-7;
using namespace std;
int main()
{
    int x,n,f,sum;
    double pie[10010];
    double maxpie,l,r,mid;
    cin >> x;
    while(x--)
    {
        scanf("%d %d",&n,&f);
        f += 1;
        maxpie = 0;
        for(int i = 0;i < n; i++)
        {
            scanf("%lf",&pie[i]);
            pie[i] *= pie[i];
            if(maxpie < pie[i])
                maxpie = pie[i];
        }
        l = 0;
        r = maxpie;
        while(r - l > eps)
        {
            sum = 0;
            mid = l + (r - l) / 2;
            for(int i = 0;i < n; i++)
                sum += (int)(pie[i] / mid);
            if(sum < f)
                r = mid;
            else
                l = mid;
        }
        printf("%.4f\n",mid * PI);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao__hei__hei/article/details/81451997