poj 2481 Cows (树状数组) ʕ •ᴥ•ʔ

Cows

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 15386   Accepted: 5128

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj. 

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi. 

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

题意:给定N个子区间,问包含第i个区间的区间有多少个。(只允许区间一个端点重合)

题解:结构体存储 起点 s 终点 e 编号 num 然后按终点按从大到小排序 若终点相同按小到大排序

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
struct ac
{
	int s,e,num;
}r[100010];
int x[100010];
int num[100010];
int cmp(ac q,ac w)//先排尾 再排头 具体自己根据样例理解 很容易懂
//尾最大的树 s到末尾这段 必定包括 
{
	if(q.e!=w.e)
	return q.e>w.e;
	return q.s<w.s;
}
int lowbit(int w)
{
	return w&-w;
}
int add(int w)
{
	while(w<=100010)
	{
		x[w]++;
		w+=lowbit(w);
	}
}
int sum(int w)
{
	int ans=0;
	while(w>0)
	{
		ans+=x[w];
		w-=lowbit(w);
	}
	return ans;
}
int main()
{
	ios::sync_with_stdio(false);
	int t;
	while(cin>>t)
	{
		if(t==0)
		break;
		memset(x,0,sizeof(x));
		memset(num,0,sizeof(num));
		for(int i=0;i<t;i++)
		{
			cin>>r[i].s>>r[i].e;
			r[i].num=i;
		}
		sort(r,r+t,cmp);
		for(int i=0;i<t;i++)
		{
			if(r[i].s==r[i-1].s&&r[i].e==r[i-1].e)
			{
				num[r[i].num]=num[r[i-1].num];//因为最多只能覆盖一个点
				// 所以当两端相同的时候 直接让其值与上一个相等 
			}
			else
			{
				num[r[i].num]=sum(r[i].s+1);
			
			}
			add(r[i].s+1);// 要再这里进行 add 
		}
		cout<<num[0];
		for(int i=1;i<t;i++)
		{
			cout<<" "<<num[i];
		}
		cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81533089
今日推荐