POJ 2481 cows 树状数组

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

又是John和John's cows的事,总的来说就是要求比一个区间大的区间有多少个。

我们先根据第一个数进行从小到大排序,再选取第二个数前面的比它大的数,

注意如果这两个区间完全相当的话不算。

树状数组解决,代码如下

#include <iostream>
#include<stdio.h>
#include<map>
#include<string.h>
#include<algorithm>
using namespace std;
//树状数组
const int maxn =100010;
int Tree[maxn+10];
inline int lowbit(int x)
{
    return (x&-x);
}
void add(int x,int value)
{
    for(int i=x;i<=maxn;i+=lowbit(i))
    {
        Tree[i]+=value;
    }
}
int get(int x)
{
    int sum=0;
    for(int i=x;i;i-=lowbit(i))
    {
        sum+=Tree[i];
    }
    return sum;
}
int tt[100010];
struct node{
int s,e;
int th;


};//th相当于一个索引
bool cmp1(node a,node b)
{
    if(a.s==b.s)
        return a.e>b.e;
    return a.s<b.s;

}//sort第一个数从小到大排,如果第一个数相等,第二个数从大到小排

 node tree[100010];

int tsl[100010];//答案都储存在这
int main()
{
    int n;
   while(scanf("%d",&n)!=EOF)
   {
       if(n==0)
        break;

for(int y=1;y<=100000;y++)
    Tree[y]=0;

   int i,a,b;
    for(i=1;i<=n;i++)
    {
        scanf("%d%d",&tree[i].s,&tree[i].e);
        tree[i].th=i;
    }
    sort(tree+1,tree+n+1,cmp1);//初始化排序
   for(i=1;i<=n;i++)
   {
     if(tree[i].e==tree[i-1].e&&tree[i].s==tree[i-1].s)
         tsl[tree[i].th]= tsl[tree[i-1].th];
       else
       tsl[tree[i].th]=get(100001)-get(tree[i].e-1);//后面比它小的数=总的-前面的

       add(tree[i].e,1);
   }
   for(i=1;i<=n;i++)
   {
       printf("%d",tsl[i]);
       if(i==n)
        printf("\n");
       else
        printf(" ");
   }
   }

    return 0;

}

猜你喜欢

转载自blog.csdn.net/swustzhaoxingda/article/details/81319882
今日推荐