POJ 2481 Cows 树状数组 单点更新 (每个集合是几个集合的真子集)

Description
Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!
Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.
Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.
Sample Input

3
1 2
0 3
3 4
0
Sample Output

1 0 0

题意:此题的s与e看作x坐标与y坐标的话,很明显求的就是左上角的奶牛数量(因为要求si<=sj 且ej≤ei)。因此将此题完全转化过去的关键在于,对输入的区间进行排序,之后按照y的降序排列,y相等时,按照x升序排列。

思路:与Stars类似,先排序按照y的降序排列,y相等时,按照x升序排列,然后和Stars处理基本相同了

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=100010;
int c[MAXN];
struct Node
{
    int S,E;
    int index;
}node[MAXN];

int n;
int cnt[MAXN];//记录结果

//先按照E从大到小排序,E相同则按照S从小到大排序
bool cmp(Node a,Node b)
{
    if(a.E==b.E)return a.S<b.S;
    return a.E>b.E;
}
int lowbit(int x)
{
    return x&(-x);
}
void add(int i,int val)
{
    while(i<=n)
    {
        c[i]+=val;
        i+=lowbit(i);
    }
}
int sum(int i)
{
    int s=0;
    while(i>0)
    {
        s+=c[i];
        i-=lowbit(i);
    }
    return s;
}
int main()
{
    while(scanf("%d",&n),n)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&node[i].S,&node[i].E);
            node[i].index=i;
        }
        sort(node+1,node+n+1,cmp);
        memset(c,0,sizeof(c));
        memset(cnt,0,sizeof(cnt));
        cnt[node[1].index]=0;
        add(node[1].S+1,1);
        for(int i=2;i<=n;i++)
        {
            if(node[i].E==node[i-1].E&&node[i].S==node[i-1].S)
               cnt[node[i].index]=cnt[node[i-1].index];
            else
                cnt[node[i].index]=sum(node[i].S+1);
            add(node[i].S+1,1);
        }
        printf("%d",cnt[1]);
        for(int i=2;i<=n;i++)
          printf(" %d",cnt[i]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/deepseazbw/article/details/81083846