poj 3660 传递闭包问题

Cow Contest
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15540   Accepted: 8657

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题目意思:有一群牛,厉害的要排在前面,输入a,b表示a比b要厉害,问有多少不能确定排名的牛,一道简单的传递闭包的题。

传递闭包大概就是。。 先将一张图用一个矩阵表示出来,矩阵中的a[i][j]=1表示i~j有一条直接相连的边。
这样就得到一个0/1矩阵。传递闭包算法的目的就是根据以上的初始矩阵,探索出最终的矩阵,
表示根据初始的直接连接关系,从初始矩阵扩展出一个包括间接连接关系的最终矩阵。这个最终矩阵就是传递闭包矩阵
代码如下:
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#include <string>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
#define M 20005
#define N 105
int map[N][N];
void fold(int sum)
{
    for(int i=1;i<=sum;i++)
        for(int j=1;j<=sum;j++)
        for(int k=1;k<=sum;k++)
        map[j][k]=map[j][k]||(map[j][i]&&map[i][k]);
}
int main()
{
    int n,m;
    cin>>n>>m;
    int a,b;
    memset(map,0,sizeof(map));
    for(int i=0;i<m;i++)
    {
        cin>>a>>b;
        map[a][b]=1;
    }
    fold(n);
    int res=0;
    for(int i=1;i<=n;i++)
       {
           int ans=0;
        for(int j=1;j<=n;j++)
    {
        if(i==j)continue;
        if(map[i][j]||map[j][i])ans++;
    }
    if(ans==n-1)res++;
       }
    cout<<res<<endl;

}
 
 

猜你喜欢

转载自www.cnblogs.com/SparkPhoneix/p/9444152.html