HDU Lowest Bit(Java版解题)

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3770 Accepted Submission(s): 2519
 

Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26
88
0

Sample Output

2
8
import java.util.ArrayList;
import java.util.Scanner;

public class Main {

	public static void main(String args[])
    {
        Scanner cin = new Scanner(System.in);
        while(cin.hasNext()){
            int m = cin.nextInt();
            if(m==0) break;
            System.out.println(Integer.lowestOneBit(m));
        }
        
    }


}

解题的时候需要注意,这里有个坑,输入输出事例那里题目描述不太准确,应该是输入一个数字然后再输出个数字

输入0结束程序运行,大家注意下吧

猜你喜欢

转载自blog.csdn.net/u012999325/article/details/81194706