3252 Lowest Unique Price

Lowest Unique Price
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description

Recently my buddies and I came across an idea! We want to build a website to sell things in a new way.

For each product, everyone could bid at a price, or cancel his previous bid, finally we sale the product to the one who offered the “lowest unique price”. The lowest unique price is defined to be the lowest price that was called only once.

So we need a program to find the “lowest unique price”, We’d like to write a program to process the customers’ bids and answer the query of what’s the current lowest unique price.

All what we need now is merely a programmer. We will give you an “Accepted” as long as you help us to write the program.
Input

The first line of input contains an integer T, indicating the number of test cases (T ≤ 60).

Each test case begins with a integer N (1 ≤ N ≤ 200000) indicating the number of operations.

Next N lines each represents an operation.

There are three kinds of operations:

“b x”: x (1 ≤ x ≤ 10^6) is an integer, this means a customer bids at price x.

“c x”: a customer has canceled his bid at price x.

“q” : means “Query”. You should print the current lowest unique price.

Our customers are honest, they won\’t cancel the price they didn’t bid at.
Output

Please print the current lowest unique price for every query (“q”). Print “none” (without quotes) if there is no lowest unique price.
Sample Input

2
3
b 2
b 2
q
12
b 2
b 2
b 3
b 3
q
b 4
q
c 4
c 3
q
c 2
q

Sample Output

none
none
4
3
2

Hint
Source
“浪潮杯”山东省第六届ACM大学生程序设计竞赛

#include <cstdio>
#include <set>
#include <map>
using namespace std;

int main()
{
    set<int>myset;
    map<int,int>mymap;
    char c;
    int t,n,x;
    scanf("%d",&t);
    while(t--){
            myset.clear();
            mymap.clear();
            scanf("%d",&n);
            for(int i =0;i<n;i++){
                scanf(" %c",&c);
                if(c=='b'){
                    scanf("%d",&x);
                    myset.insert(x);
                    mymap[x]++;
                    if(mymap[x]>1) myset.erase(x);

                }
                else if(c == 'c'){
                    scanf("%d",&x);
                    mymap[x]--;
                    if(mymap[x]==1) myset.insert(x);
                    else if(mymap[x]==0) myset.erase(x);
                }
                else {
                    if(!myset.empty())
                        printf("%d\n",*myset.begin());
                    else
                        printf("none\n");

                }
            }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hanyanwei123/article/details/80192158
今日推荐