HDU -2028 Lowest Common Multiple Plus

求n个数的最小公倍数。

Input

输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

Output

为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

Sample Input

2 4 6
3 2 5 7

Sample Output

12
70
#include<stdio.h>
#include<math.h>
int main()
{
	int n,i;
	long t ,a[1001];
	while(scanf("%d",&n)!=EOF)
	{
	for(i=0;i<n;i++)
	{
		scanf("%ld",&a[i]);
		t=a[0];
		if(t<a[i])
		t=a[i];
	}
	
	for(i=0;i<n;)
	{
		 if(t%a[i]!=0)//旨在求出t和a[i]的最小公倍数
		 {
			 t++;
			 i=0;
		 }
		 else
			 i++;
	}
	printf("%ld\n",t);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y_yunhu/article/details/81291528
今日推荐