不敢死队问题

不敢死队问题
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
说到“敢死队”,大家不要以为我来介绍电影了,因为数据结构里真有这么道程序设计题目,原题如下:

有M个敢死队员要炸掉敌人的一个碉堡,谁都不想去,排长决定用轮回数数的办法来决定哪个战士去执行任务。如果前一个战士没完成任务,则要再派一个战士上去。现给每个战士编一个号,大家围坐成一圈,随便从某一个战士开始计数,当数到5时,对应的战士就去执行任务,且此战士不再参加下一轮计数。如果此战士没完成任务,再从下一个战士开始数数,被数到第5时,此战士接着去执行任务。以此类推,直到任务完成为止。

这题本来就叫“敢死队”。“谁都不想去”,就这一句我觉得这个问题也只能叫“不敢死队问题”。今天大家就要完成这道不敢死队问题。我们假设排长是1号,按照上面介绍,从一号开始数,数到5的那名战士去执行任务,那么排长是第几个去执行任务的?

Input
输入包括多试数据,每行一个整数M(0<=M<=10000)(敢死队人数),若M==0,输入结束,不做处理。

Output
输出一个整数n,代表排长是第n个去执行任务。

Sample Input
9
6
223
0
Sample Output
2
6
132
Hint

Source

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int date;
    struct node *next;
};
struct node *creat(int n);
int sel(struct node *head,int n,int m);
int main()
{
    struct node *head;
    int n,m=5;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        head=creat(n);
        printf("%d\n",sel(head,n,m));
    }
    return 0;
}
struct node *creat(int n)
{
   int i;
   struct node *head,*tail,*p;
   p=(struct node*)malloc(sizeof(struct node));
   p->date=1;
   p->next=NULL;
   head=p;
   tail=p;
   for(i=2;i<=n;i++)
   {
       p=(struct node*)malloc(sizeof(struct node));
       p->date=i;
       tail->next=p;
       tail=p;
       p->next=NULL;
   }
   tail->next=head;
   return head;
}
int sel(struct node *head,int n,int m)
{
    struct node *p,*q;
    int count=0,num=1;
    p=head;
    q=head;
    while(q->next!=head)
        q=q->next;
    while(count<n)
    {
        if(num==m)
        {
            if(p->date==1)
            {
                count++;
                break;
            }
            q->next=p->next;
            free(p);
            p=q->next;
            count++;
            num=1;
        }
        else
        {
            num++;
            q=p;
            p=p->next;
        }
    }
    return count;
}

猜你喜欢

转载自blog.csdn.net/Dmenghu/article/details/81325421