数据结构实验之数组一:矩阵转置

数据结构实验之数组一:矩阵转置
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
数组——矩阵的转置
给定一个m*n的矩阵(m,n<=100),求该矩阵的转置矩阵并输出。

Input
输入包含多组测试数据,每组测试数据格式如下:
第一行包含两个数m,n
以下m行,每行n个数,分别代表矩阵内的元素。
(保证矩阵内的数字在int范围之内)

Output
对于每组输出,输出给定矩阵的转置矩阵。两组输出之间用空行隔开。

Sample Input
2 3
1 2 3
4 5 6
1 1
1
Sample Output
1 4
2 5
3 6

1
Hint

Source
赵利强

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    int i,j,m,n,a[110][110];
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        for(i=1;i<=m;i++)
            for(j=1;j<=n;j++)
            scanf("%d",&a[i][j]);
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            if(j!=m) //判断是否是该行的最后一个数
                printf("%d ",a[j][i]);
            else
                printf("%d\n",a[j][i]); //行列互换输出
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Dmenghu/article/details/81449885