2018 Multi-University Training Contest 4.Problem D. Nothing is Impossible(水题)

m students, including Kazari, will take an exam tomorrow.
The paper consists of exactly n problems, the i-th problem contains ai correct answers and bi incorrect answers, i.e. the i-th problem contains ai+bi candidates in total.
Each student should choose exactly one candidate as answer for each problem. If the answer to a certain problem is correct, then the student will get one point. The student who gets the most points wins.
Students only know the structure of the paper, but they are able to talk with each other during the exam. They decide to choose a subset S of all n problems, and they will only be able to submit answers on these problems.
They want to know the maximum size of S that the winner among them will solve all the problems in S if they take the optimal strategy.


For sample 1, students can choose S={1},and we need at least 4 students to guarantee the winner solve the only problem.

For sample 2, students can choose S={1,2,3}, and we need at least 24 students to guarantee the winner solve these three problems, but if |S|=4, we need at least 96 students, which is more than 50.

Input

The first line of the input contains an integer T (1≤T≤100) denoting the number of test cases.
Each test case starts with two integers n,m (1≤n≤100,1≤m≤109), denoting the number of problems and the number of students. Each of next n lines contains two integers ai,bi (1≤bi≤100,ai=1), indicating the number of correct answers and the number of incorrect answers of the i-th problem.

Output

For each test case, print an integer denoting the maximum size of S.

Sample Input

 

2 3 5 1 3 1 3 1 3 5 50 1 1 1 3 1 2 1 3 1 5

Sample Output

 

1 3

 解题思路:按照最优策略,将正错比最高按照从高到低进行排序,依次求出排序后保持正确的人数,直到在下一次分配中无法满足剩余的正确人数完全覆盖正确和错误结果,则计数完毕。

#include<bits/stdc++.h>
using namespace std;
struct pp
{
    double z,c;
}p[103];
bool cmp(pp x,pp y)
{
    return x.z/x.c>y.z/y.c;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        double m;
        scanf("%d%lf",&n,&m);
        for(int i=0;i<n;i++)
           scanf("%lf%lf",&p[i].z,&p[i].c);
        sort(p,p+n,cmp);
        
        int sum=0;
        for(int i=0;i<n;i++)
        {
           if(m>=p[i].z+p[i].c)
           {
               m=(int)(m*p[i].z/(p[i].z+p[i].c)+0.1);
               sum++;
           }
           else
               break;
        }
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/XxxxxM1/article/details/81353078
今日推荐