2018 杭电暑期多校第四场 Problem L. Graph Theory Homework

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6343

Problem L. Graph Theory Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 366    Accepted Submission(s): 225

Problem Description

There is a complete graph containing n vertices, the weight of the i-th vertex is wi.
The length of edge between vertex i and j (i≠j) is ⌊|wi−wj|−−−−−−−√⌋.
Calculate the length of the shortest path from 1 to n.

Input

The first line of the input contains an integer T (1≤T≤10) denoting the number of test cases.
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph.
The second line contains n integers, the i-th integer denotes wi (1≤wi≤105).

Output

For each test case, print an integer denoting the length of the shortest path from 1 to n.

Sample Input

1 3 1 3 5

Sample Output

2

Source

2018 Multi-University Training Contest 4

Recommend

chendu   |   We have carefully selected several similar problems for you:  6343 6342 6341 6340 6339 

 

题意:给你N个点,两点之间的移动花费为\sqrt{\left | a[i]-b[i] \right |},求一个初始点到n点的最小花费

思路:福利签到题,因为2\sqrt{\left ( ab \right )}>=0,

                                所以a+b+2\sqrt{ab}>=a+b,

                                所以(\sqrt{a}+\sqrt{b})^{2}>=(\sqrt{a+b})^{2}

                                所以\sqrt{a}+\sqrt{b}>=\sqrt{a+b}

          那么想要花费最小,从源点直飞终点花费是最小的

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>

using namespace std;

#define inf 0x3f3f3f3f

const int maxn=1e5+7;

int a[maxn];

int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        for (int i = 0; i < n; ++i)
        {
            scanf("%d",&a[i]);
        }
        long long ans=abs(a[0]-a[n-1]);
        ans=sqrt(ans);
        printf("%lld\n",ans);
    }
    return 0;
}

         

猜你喜欢

转载自blog.csdn.net/leper_gnome/article/details/81352443