hdu 6343 Graph Theory Homework(水)

There is a complete graph containing n vertices, the weight of the i-th vertex is wi.
The length of edge between vertex i and j (i≠j) is ⌊|wi−wj|−−−−−−−√⌋.
Calculate the length of the shortest path from 1 to n
.
Input
The first line of the input contains an integer T (1≤T≤10) denoting the number of test cases.
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph.
The second line contains n integers, the i-th integer denotes wi (1≤wi≤105)
.
Output
For each test case, print an integer denoting the length of the shortest path from 1 to n
.
Sample Input

1
3
1 3 5

Sample Output

2
#include<bits/stdc++.h>
using namespace std;

int main(){
    int t, n, w[100010];
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        for(int i = 1; i <= n; i++){
            scanf("%d", &w[i]);
        }
        double len = abs(w[1] - w[n]);
        int lens = (int)sqrt(len);
        printf("%d\n", lens);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81475339