HDU 6343 Graph Theory Homework(水题)

Problem Description

There is a complete graph containing n vertices, the weight of the i -th vertex is wi .
The length of edge between vertex i and j (i≠j) is ⌊|wi−wj|−−−−−−−√⌋ .
Calculate the length of the shortest path from 1 to n .

Input

The first line of the input contains an integer T (1≤T≤10) denoting the number of test cases.
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph.
The second line contains n integers, the i -th integer denotes wi (1≤wi≤105) .

Output

For each test case, print an integer denoting the length of the shortest path from 1 to n .

 

Sample Input

 

1

3

1 3 5

Sample Output

 

2

贴过来后公式混乱,题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6343

题目大意:给出边权求最短路。

思路:嗯,最短路,套模板,dij?不行,10^5,SPFA?来一发,,套模板也超时???看神仙的提交记录,0ms?看来有问题。然后发现,,,两点之间直线最短...(题解中说的是三角形两边和大于第三边)。

代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int k[100005];
int main()
{
    int n,m;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&m);
        for(int i=0;i<m;i++) scanf("%d",&k[i]);
        //sort(k,k+m);
        int b=abs(k[m-1]-k[0]);
        int c=int(sqrt(b));
        printf("%d\n",c);
    }
} 

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/81353244