Constructing Roads(prime算法)

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 27201   Accepted: 11969

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source


理解题意:

有N村庄,给出各村庄之间修路所需花费 和 己经连接好的村庄,求把村庄都连起来的最小花费。


解法:

基础prime算法,生成最小树。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MM=110;
const int INF=0x3f3f3f3f;
int tu[MM][MM],dis[MM],book[MM];
int n,s,d,r;
int main()
{
    int i,j,fl,ans=0;
    scanf("%d",&n);
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=n; j++)
        {
            scanf("%d",&tu[i][j]);
        }
    }
    scanf("%d",&r);
    for(i=1; i<=r; i++)
    {
        scanf("%d%d",&s,&d);   //已连好的村庄记为0
        tu[s][d]=tu[d][s]=0;
    }
    for(i=1;i<=n;i++)
            dis[i]=tu[1][i];
    memset(book,0,sizeof(book));
    book[1]=1;
    for(i=1;i<n;i++)
    {
        int minn=INF;
        for(j=1;j<=n;j++)
        {
            if(dis[j]<minn&&!book[j])
            {
                minn=dis[j];
                fl=j;
            }
        }
        book[fl]=1;
        ans+=minn;       //最小生成树总长度
        for(int v=1;v<=n;v++)
        {
            if(dis[v]>tu[fl][v]&&!book[v])
            {
                dis[v]=tu[fl][v];
            }
        }
    }
    printf("%d\n",ans);
        return 0;
}

猜你喜欢

转载自blog.csdn.net/team39/article/details/81041944