D - Highways(最小生成树 prim)

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9

1 5

0 0

3 2

4 5

5 1

0 4

5 2

1 2

5 3

3

1 3

9 7

1 2

Sample Output

1 6

3 7

4 9

5 7

8 3

  • 题意概括  :

给你n个城镇,和城镇的坐标,然后给你m条道路,表示已经建好的道路,问怎样建造使各个城镇连通起来使得路径最短,输出所需要建造的路径。

  • 解题思路  :

首先,用一个map数组记录各城镇之间距离的平方,然后把已有道路的路径长变为零,然后prim算法,找出最优路径,判断map数组是否为零,如果不为零输出所在路径的城镇编号。

#include<stdio.h>
#include<math.h>
#include<string.h>

int x[755],y[755],dis[755],book[755],p[755],map[755][755];
int n,m,a,b;
int inf = 99999999;

int prim()
{
	int i,j,k,count,min;
	memset(book,0,sizeof(book));
	for(i = 1;i<=n;i ++)
	{
		dis[i] = map[1][i];
		p[i] = 1;
	}
	book[1] = 1;
	dis[1] = 0;
	count = 0;
	
	while(count < n)
	{
		min = inf;
		j = 0;
		for(i = 1;i<=n;i++)
		{
			if(book[i] == 0&&dis[i]<min)
			{
				min = dis[i];
				j = i;
			}
		}
		book[j] = 1;
		count ++;
		if(map[p[j]][j] != 0)
		printf("%d %d\n",j,p[j]);
		for(k = 1;k<=n;k++)
		{
			if(book[k] == 0&&dis[k] > map[j][k])
			{
				dis[k] = map[j][k];
				p[k] = j;
			}
		}
	}
}
int main()
{
	int i,j;
	
	while(~ scanf("%d",&n))
	{
		for(i = 1;i<=n;i ++)
		{
			scanf("%d %d",&x[i],&y[i]);
			for(j = 1;j<=n;j ++)
			{
				map[i][j] = map[j][i] = (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
			}
		}
		scanf("%d",&m);
		for(i = 1;i<=m;i ++)
		{
			scanf("%d%d",&a,&b);
			map[a][b] = map[b][a] = 0;
		}
		prim();
	}
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81333068