pat L1-2 倒数第N个字符串(15 分)

L1-2 倒数第N个字符串(15 分)

给定一个完全由小写英文字母组成的字符串等差递增序列,该序列中的每个字符串的长度固定为 L,从 L 个 a 开始,以 1 为步长递增。例如当 L 为 3 时,序列为 { aaa, aab, aac, ..., aaz, aba, abb, ..., abz, ..., zzz }。这个序列的倒数第27个字符串就是 zyz。对于任意给定的 L,本题要求你给出对应序列倒数第 N 个字符串。

输入格式:

输入在一行中给出两个正整数 L(2 ≤ L ≤ 6)和 N(≤10​5​​)。

输出格式:

在一行中输出对应序列倒数第 N 个字符串。题目保证这个字符串是存在的。

输入样例:

3 7417

输出样例:

pat
#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#include<bits/stdc++.h>
#define ll long long
const int maxn=100000000;
using namespace std;
int r[maxn];
int pow(int a,int b)
{
	int ans=1;
	while(b)
	{
		if(b&1)
		ans=ans*a;
		a=a*a;
		b/=2;
	}
	return ans;
}
char a[maxn];
int main()
{
	 	int l,n,j=0;
	 	cin>>l>>n;
	 	int q=pow(26,l)-n;
	 	for(int i=l-1;i>=0;i--)
	 	{
	 		a[j]=q/pow(26,i)+'a';
	 		q=q%pow(26,i);
	 		j++;
	 	}
	 	for(int i=0;i<l;i++)
	 		printf("%c",a[i]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41453511/article/details/81431514