Tri Tiling

In how many ways can you tile a 3xn rectangle with 2x1 dominoes? 
Here is a sample tiling of a 3x12 rectangle. 

Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.

Output

For each test case, output one integer number giving the number of possible tilings.

Sample Input

2
8
12
-1

Sample Output

3
153
2131
#include<iostream>
#include<cstdio>
using namespace std;
int a[35];
int main()
{
	int n;
	a[0]=1;
	a[2]=3;
	for(int i=4;i<=30;i+=2)
	    a[i]=a[i-2]*4-a[i-4];
	while(~scanf("%d",&n)&&n!=-1)
	{
	    printf("%d\n",a[n]);	
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/PeopleOfVision/article/details/81407912