Median

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi- Xj∣ (1 ≤ i j N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

题目大意:给你n个数,你需要求出所有差值中的中值。

分析:二分搜索差值的中值,计算有多少组数字的差值小于等于这个值。(二分查找)如果有k对,且k>=总对数的一半,那么向左查找;否则向右查找。

时间复杂度O(log n* n * log n)


#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
    int n,i,l,r,li,ri,mi,m,a[100010];
    long long o,ans;
    
    while (~scanf("%d",&n)){
        for (i=1;i<=n;i++) scanf("%d",&a[i]);
        
        sort(a+1,a+n+1);
        
        l=0;r=1000000010;
    
        o=((long long)n*(n-1)/2+1)/2;          //如果总对数是偶数 取中间偏左的值 是奇数就直接取中间值
        
        while (l<r){
            m=(l+r)>>1;
            ans=0;
            for (i=1;i<=n;i++){
                li=i;
                ri=n;
                while(li<ri)
                {
                    mi=(li+ri+1)>>1;         //如果不加一,可能会出现死循环的情况
                       if(a[mi]-a[i]<=m) li=mi;
                       else ri=mi-1;
                   }
                ans+=ri-i;
            }
            
            if (ans>=o) r=m;           //不会出现死循环
            else l=m+1;
        }
        
        printf("%d\n",l);
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41703679/article/details/79310526