搜索--B - Dungeon Master (三维空间)

        You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).

Trapped!

1.在进入题目之前,先来一个广度优先搜索的讲解(哈哈,因为还不太熟悉,老是记不住到底该用深度还是广度),只要是求全解,也就是所有情况的,就用深度搜索。若只是求最优解,那就用广度。

2.深度广度讲解:https://www.cnblogs.com/Leo_wl/p/6251022.html

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
char map[35][35][35];
int vis[35][35][35];
int dir[6][3] = {{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};
int k,n,m;
int sx,sy,sz,ex,ey,ez;
typedef struct node
{
    int x,y,z,step;
}node;
int judge(int x,int y,int z)
{
   if(x<0||y<0||z<0||x>=k||y>=n||z>=m||map[x][y][z]=='#'||vis[x][y][z])
        return 1;
    else
        return 0;
}
int bfs()
{
    node a,next;//next就相当于一个中转站一样 
    queue<node>q;
    a.x=sx,a.y=sy,a.z=sz;
    a.step=0;
    vis[sx][sy][sz]=1;
    q.push(a);//单纯的把a加入到队列中而已 
    while(!q.empty())
    {
        a=q.front();//把队列p中的第一个元素取出来给a 
        q.pop();//用完后就删除 
        if(a.x==ex&&a.y==ey&&a.z==ez)
            return a.step;
        for(int i=0; i<6; i++)
        {
            next=a;
            next.x=a.x+dir[i][0];
            next.y = a.y+dir[i][1];
            next.z = a.z+dir[i][2];
            if(judge(next.x,next.y,next.z))
            {
                continue;
            }
            vis[next.x][next.y][next.z] = 1;
            next.step=a.step+1;
            q.push(next);//讲next加入到队列之中 
        }
    }
    return 0;
}


int main()
{
    int i,j,r;
    while(~scanf("%d%d%d",&k,&n,&m))
    {
    	if(k==0&&n==0&&m==0)
    	  break;
        for(i=0; i<k; i++)
        {
            for(j=0; j<n; j++)
            {
                scanf("%s",map[i][j]);
                for(r=0; r<m; r++)
                {
                    if(map[i][j][r]=='S')
                    {
                        sx=i,sy=j,sz=r;
                    }
                    if(map[i][j][r]=='E')
                    {
                        ex=i,ey=j,ez=r;
                    }
                }
            }
        }
        memset(vis,0,sizeof(vis));
        int ans=0;
        ans=bfs();
        if(ans)
            printf("Escaped in %d minute(s).\n",ans);
        else
            printf("Trapped!\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/SSYITwin/article/details/80315085