CF1003C Intense Heat递推

  

题目描述

The heat during the last few days has been really intense. Scientists from all over the Berland study how the temperatures and weather change, and they claim that this summer is abnormally hot. But any scientific claim sounds a lot more reasonable if there are some numbers involved, so they have decided to actually calculate some value which would represent how high the temperatures are.

Mathematicians of Berland State University came up with a special heat intensity value. This value is calculated as follows:

Suppose we want to analyze the segment of n n n consecutive days. We have measured the temperatures during these n n n days; the temperature during i i i -th day equals ai a_i ai​ .

We denote the average temperature of a segment of some consecutive days as the arithmetic mean of the temperature measures during this segment of days. So, if we want to analyze the average temperature from day x x x to day y y y , we calculate it as ∑i=xyaiy−x+1 \frac{\sum \limits_{i = x}^{y} a_i}{y - x + 1} y−x+1i=x∑y​ai​​ (note that division is performed without any rounding). The heat intensity value is the maximum of average temperatures over all segments of not less than k k k consecutive days. For example, if analyzing the measures [3,4,1,2] [3, 4, 1, 2] [3,4,1,2] and k=3 k = 3 k=3 , we are interested in segments [3,4,1] [3, 4, 1] [3,4,1] , [4,1,2] [4, 1, 2] [4,1,2] and [3,4,1,2] [3, 4, 1, 2] [3,4,1,2] (we want to find the maximum value of average temperature over these segments).

You have been hired by Berland State University to write a program that would compute the heat intensity value of a given period of days. Are you up to this task?

输入输出格式

输入格式:

The first line contains two integers n n n and k k k ( 1≤k≤n≤5000 1 \le k \le n \le 5000 1≤k≤n≤5000 ) — the number of days in the given period, and the minimum number of days in a segment we consider when calculating heat intensity value, respectively.

The second line contains n n n integers a1 a_1 a1​ , a2 a_2 a2​ , ..., an a_n an​ ( 1≤ai≤5000 1 \le a_i \le 5000 1≤ai​≤5000 ) — the temperature measures during given n n n days.

输出格式:

Print one real number — the heat intensity value, i. e., the maximum of average temperatures over all segments of not less than k k k consecutive days.

Your answer will be considered correct if the following condition holds: ∣res−res0∣<10−6 |res - res_0| < 10^{-6} ∣res−res0​∣<10−6 , where res res res is your answer, and res0 res_0 res0​ is the answer given by the jury's solution.

输入输出样例

输入样例#1: 复制

4 3
3 4 1 2

输出样例#1: 复制

2.666666666666667

题意:在数列大于等于k长度的连续区间内,求最大平均值

思路:通过sum【】算出从开始到每一个数(包括)的和,然后区间内的和为sun[j]-sun[i-j-1],通过循环求出最大平均值

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
long long int a[5008],sum[5008];
int main()
{
    int n,lenth;
    double max_ave=0;
    scanf("%d%d",&n,&lenth);
    for(int i=1;i<=n;i++)
    {
        scanf("%lld",&a[i]);
    }
    sum[0]=0;
    for(int i=1;i<=n;i++)
        sum[i]=sum[i-1]+a[i];
    for(int j=lenth;j<=n;j++)
    {
        for(int i=1;i+j<=n+1;i++)
        {
            max_ave=max(max_ave,double(sum[i+j-1]-sum[i-1])/j);
        }
    }
    printf("%.15lf",max_ave);
    return 0;


}

猜你喜欢

转载自blog.csdn.net/sunpeishuai/article/details/81318594
今日推荐