Hdu6318Swaps and Inversions

Swaps and Inversions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


 

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

 

Output

For every test case, a single integer representing minimum money to pay.

 

扫描二维码关注公众号,回复: 2505476 查看本文章

Sample Input

 

3 233 666 1 2 3 3 1 666 3 2 1

 

Sample Output

 

0 3

 设cnt是给定数列的逆序数

之前看到过,如果要是相邻两个元素交换,那么将数列排成有序需要cnt次

那么,其实ans  =  k*(y-x)   +    (cnt-k)x  (0<=k<=cnt)

你看啊,如果y>x,那么交换一次的花费比不交换要高,那就不交换了,全部是x就好

否则,全交换不就完了,所以

最后输出很简单,ans = min(x*cnt,y*cnt)

怎么求逆序数呐,这里、

代码稍微改改就好

这里贴上我的一个(略有不同哦)

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
int n,tree[100010];
void add(int k,int num)
{
    while(k<=n)
    {
        tree[k]+=num;
        k+=k&-k;
    }
}

int query(int k)
{
    int sum=0;
    while(k)
    {
        sum+=tree[k];
        k-=k&-k;
    }
    return sum;
}
struct node
{
    int x,i;
    bool operator < (const node &a) const
    {
        if(x!=a.x)
            return x<a.x;
        return i<a.i;
    }
}p[100010];
int b[100010];
int main(void)
{
    int i,j,x,y;

    while(~scanf("%d%d%d",&n,&x,&y))
    {
        ll sum = 0;
        memset(tree,0,sizeof(tree));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&p[i].x);
            p[i].i = i;
        }
        sort(p+1,p+1+n);
        int cnt = 1;
        for(i=1;i<=n;i++)
        {
            add(p[i].i,1);
            sum += (i-query(p[i].i));
        }
        printf("%lld\n",min(x*sum,y*sum));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/du_mingm/article/details/81208954
今日推荐