HDU6318 Swaps and Inversions(离散化+树状数组)

Swaps and Inversions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1317    Accepted Submission(s): 481

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

Output

For every test case, a single integer representing minimum money to pay.

Sample Input

3 233 666 1 2 3 3 1 666 3 2 1

Sample Output

0 3

Source

2018 Multi-University Training Contest 2

Recommend

chendu   |   We have carefully selected several similar problems for you:  6318 6317 6316 6315 6314 

树状数组求逆序数+数据离散化

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define lowbit(x) x&(-x)
#define LL long long
using namespace std;
LL tree[100005], n, x, y;
struct A
{
    LL x, y;
    bool operator < (A & a) const{
        if(x==a.x) return y < a.y;     //没有这句判断会WA
        return x < a.x;
    }
}a[100005];
inline void add(LL x)
{
    while(x<=n){
        tree[x] ++;
        x+=lowbit(x);
    }
}
inline LL getsum(LL x)
{
    LL sum = 0;
    while(x>0){
        sum += tree[x];
        x-=lowbit(x);
    }
    return sum;
}

int main()
{
    while(scanf("%lld%lld%lld", &n, &x, &y) != EOF)
    {
        fill(tree, tree+n+1, 0);
        for(LL i=1; i<=n; i++)
        {
            scanf("%lld", &a[i].x);
            a[i].y = i;
        }
        sort(a+1, a+1+n);
        LL ans = 0;
        for(LL i=1; i<=n; i++)
        {
            add(a[i].y);
            ans += i-getsum(a[i].y);
        }
        printf("%lld\n", ans*min(x,y));
    }
}

猜你喜欢

转载自blog.csdn.net/A_Thinking_Reed_/article/details/81228476
今日推荐