HDU 6318 Swaps and Inversions(归并)

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

Output

For every test case, a single integer representing minimum money to pay.

Sample Input

 

3 233 666

1 2 3

3 1 666

3 2 1

Sample Output

 

0

3

题目大意:给出n个数,交换一对逆序对需要支付x元,交换相邻的2个元素需要支付y元。规定先交换逆序对再交换相邻。求最小支付的钱。

思路:求逆序对,再乘以xy较小的一个。

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
long long int a[500010],temp[500010];
long long int ans,n;
void mergearray(int s,int e){ 
    if(s==e) //等于退出 
        return;
    int i;
    int mid=(s+e)>>1;//右移,相当于(s+e)/2 
    int l=s, r=mid+1, k=s;
    while(l<=mid&&r<=e){
        if(a[l]<=a[r]){
            temp[k]=a[l++];
        } else {
            temp[k]=a[r++];
            ans+=mid-l+1;//需要移动的位移差 
        }
        k++;
    }
    //把遗漏的加到数组里 
    while(l<=mid) 
        temp[k++]=a[l++];
    while(r<=e) 
        temp[k++]=a[r++];
    for(i=s;i<=e; i++) 
        a[i]=temp[i];
    return ;
}
void sortd(int s,int e){
    if(s>=e) 
        return;
    int mid=(s+e)>>1;
    sortd(s,mid);//左递归合并 
    sortd(mid+1,e);//右递归合并 
    mergearray(s,e);//合并细化(排序)后的数组 
    return;
}
int main(){
    int i,j,k,n,x,y;
    while(~scanf("%d%d%d",&n,&x,&y)){
        long int mm=min(x,y);
        ans=0;
        for(i=1;i<=n;i++){
            scanf("%lld",&a[i]);
        }
        sortd(1,n);
        printf("%lld\n",ans*mm);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/pleasantly1/article/details/81214683
今日推荐