Dollar Dayz

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 
 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

 

5 3

Sample Output

 

5

求k以内的整数组成n有多少种方案

完全背包,注意范围,可以用两个long long拼合

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int n,k;
int inf=1;
long long  a[1005];
long long b[1005];
int main()
{for(int i=0;i<18;i++)
inf*=10;
    scanf("%d%d",&n,&k);
    a[0]=1;
    for(int i=1;i<=k;i++)
    {
        for(int j=1;j<=n;j++)
        {if(j<i)
        continue;
        b[j]=b[j]+b[j-i]+(a[j]-a[i])/inf;
        a[j]=(a[j]+a[j-i])%inf;}
    }
    if(b[n])
    printf("%I64d",b[n]);
    printf("%I64d",a[n]);
    return 0;

}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81228370
今日推荐