求最小值,二分法

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
 
  
2 100 200
 

Sample Output
 
  
-74.4291 -178.8534
 
 #include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
double y;
double mm(double x)
{return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
double jj()
{ double a=0,b=100,p;
 double eps=pow(10,-6);
 while(b-a>=eps)
 {p=(a+b)/2;
 if(mm(p)>0)
 b=p;
 else
 a=p;
 }
 return p;
 }
 
double ee()
{  
return 6*pow(jj(),7)+8*pow(jj(),6)+7*pow(jj(),3)+5*pow(jj(),2)-y*jj();
}

int main()
{int t;
cin>>t;
for(int i=1;i<=t;i++)
{  cin>>y;
printf("%.4lf",ee());
}
}

猜你喜欢

转载自blog.csdn.net/qq_40859951/article/details/79471010