P2854-牛的过山车Cow Roller Coaster -dfs剪枝

题目描述

The cows are building a roller coaster! They want your help to design as fun a roller coaster as possible, while keeping to the budget.

The roller coaster will be built on a long linear stretch of land of length L (1 ≤ L ≤ 1,000). The roller coaster comprises a collection of some of the N (1 ≤ N ≤ 10,000) different interchangable components. Each component i has a fixed length Wi (1 ≤ Wi ≤ L). Due to varying terrain, each component i can be only built starting at location Xi (0 ≤ Xi ≤ L - Wi). The cows want to string together various roller coaster components starting at 0 and ending at L so that the end of each component (except the last) is the start of the next component.

Each component i has a "fun rating" Fi (1 ≤ Fi ≤ 1,000,000) and a cost Ci (1 ≤ Ci ≤ 1000). The total fun of the roller coster is the sum of the fun from each component used; the total cost is likewise the sum of the costs of each component used. The cows' total budget is B (1 ≤ B ≤ 1000). Help the cows determine the most fun roller coaster that they can build with their budget.

奶牛们正打算造一条过山车轨道.她们希望你帮忙,找出最有趣,但又符合预算 的方案. 过山车的轨道由若干钢轨首尾相连,由x=0处一直延伸到X=L(1≤L≤1000)处.现有N(1≤N≤10000)根钢轨,每根钢轨的起点 Xi(0≤Xi≤L- Wi),长度wi(l≤Wi≤L),有趣指数Fi(1≤Fi≤1000000),成本Ci(l≤Ci≤1000)均己知.请确定一 种最优方案,使得选用的钢轨的有趣指数之和最大,同时成本之和不超过B(1≤B≤1000).

输入输出格式

输入格式:

Line 1: Three space-separated integers: L, N and B.

Lines 2..N+1: Line i+1 contains four space-separated integers, respectively: Xi, Wi, Fi, and Ci.

输出格式:

Line 1: A single integer that is the maximum fun value that a roller-coaster can have while staying within the budget and meeting all the other constraints. If it is not possible to build a roller-coaster within budget, output -1.

输入输出样例

输入样例#1: 

5 6 10
0 2 20 6
2 3 5 6
0 1 2 1
1 1 1 3
1 2 5 4
3 2 10 2

输出样例#1:

17

说明

Taking the 3rd, 5th and 6th components gives a connected roller-coaster with fun value 17 and cost 7. Taking the first two components would give a more fun roller-coaster (25) but would be over budget.

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
int idline[1100][11000],f[1100];
int l,n,b;
int ans=-1;
struct node
{
    int x,w,f,c; //x起点 w长度 f有趣程度 c花费
}a[11000];

int cmp(node a,node b)
{
    return a.f>b.f; //有趣程度从大到小降序
}

int dfs(int id,int money,int funny)
{
    if(money>b)
        return 0; //花费超出
    if(funny<f[a[id].x+a[id].w])//且预算不会超出,且有趣程度比“前辈”(过去到了这个距离的前辈)大
        return 0;

    f[a[id].x+a[id].w]=funny;

    if(a[id].x+a[id].w==l) //到了终点就保存
    {
        ans=max(ans,funny);
        return 0;
    }

    for(int i=1;i<=idline[a[id].w+a[id].x][0];i++)//以此为起点,开始dfs
    {
        int start=a[id].w+a[id].x;
        dfs(idline[start][i],money+a[idline[start][i]].c,funny+a[idline[start][i]].f);
    }
}

int main()
{
        scanf("%d%d%d",&l,&n,&b);
        for(int i=1;i<=n;i++)
            scanf("%d%d%d%d",&a[i].x,&a[i].w,&a[i].f,&a[i].c);

        sort(a+1,a+n+1,cmp); //从大到小排序有趣程度

        for(int i=1;i<=n;i++)
        {
            idline[a[i].x][0]++;//计数
            idline[a[i].x][idline[a[i].x][0]]=i; //计数每个轨道的起点
        }

        dfs(0,0,0);

        printf("%d\n",ans);
        return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/81232748