Knight Moves (bfs查找最短路径)

Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.  

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.  
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.  
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".  
 

Sample Input
e2 e4a1 b2b2 c3a1 h8a1 h7h8 a1b1 c3f6 f6
 

Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.
 

题意:就是在一个8×8的坐标系中,已知起点和终点,查找到达终点走的最少的步数。

行走的方案只能走1×2的方格 ,因此,没走一步 ,都有8个方向的选择。

代码:

#include <stdio.h>
#include <string.h>
#include <queue>
#include<algorithm>
using namespace std;
int ter[8][2] = {-2,1,-1,2,1,2,2,1,2,-1,1,-2,-1,-2,-2,-1};  //八个方向
int vis[10][10];   //标记数组,不能重复走
char str1[5],str2[5];
struct node
{
    int x,y,member;  //bfs使用结构体
};
int bfs()
{
    int i,u,v;
    queue<node> q;
    node now,no;
    now.x = str1[0]-'a';
    now.y = str1[1]-'1';
    now.member = 0;
    u = str2[0]-'a';
    v = str2[1]-'1';
    memset(vis,0,sizeof(vis));
    vis[now.x][now.y] = 1;
    q.push(now);
    while(!q.empty())
    {
        now = q.front();
        q.pop();
        if(now.x == u && now.y == v)
        return now.member;
        for(i=0;i<8;i++)
        {
            no.x = now.x+ter[i][0];
            no.y = now.y+ter[i][1];
            no.member=now.member+1;

            if(no.x == u && no.y == v)
            return no.member;

            if(no.x>=0&&no.x<8&&no.y>=0&&no.y<8&&vis[no.x][no.y]==0){
                vis[no.x][no.y] = 1;
                q.push(no);
            }

        }
    }
    return 0;
}

int main()
{
    memset(str1,'\0',sizeof(str1));
    memset(str2,'\0',sizeof(str2));

    while(scanf("%s %s",str1,str2)!=EOF)
    {
        printf("To get from %s to %s takes %d knight moves.\n",str1,str2,bfs());
        memset(str1,'\0',sizeof(str1));
        memset(str2,'\0',sizeof(str2));
    }
    return 0;
}
下面这个代码,我感觉很对,就是有错

猜你喜欢

转载自blog.csdn.net/dong_qian/article/details/80644220