Balanced Sequence(多校,排序规则)

Problem Description

Chiaki has n strings s1,s2,…,sn consisting of '(' and ')'. A string of this type is said to be balanced:

+ if it is the empty string
+ if A and B are balanced, AB is balanced,
+ if A is balanced, (A) is balanced.

Chiaki can reorder the strings and then concatenate them get a new string t. Let f(t) be the length of the longest balanced subsequence (not necessary continuous) of t. Chiaki would like to know the maximum value of f(t) for all possible t.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤105) -- the number of strings.
Each of the next n lines contains a string si (1≤|si|≤105) consisting of `(' and `)'.
It is guaranteed that the sum of all |si| does not exceeds 5×106.

Output

For each test case, output an integer denoting the answer.

Sample Input

2 1 )()(()( 2 ) )(

Sample Output

4 2

Source

2018 Multi-University Training Contest 1

主要是排序规则。

代码:

#include <bits/stdc++.h>

using namespace std;
#define ll long long
const int maxn=1e5+10;
char b[maxn];
ll sum;
struct poin
{
    int l,r;
}G[maxn];
int cmp(poin a,poin b)
{
    int x = min(a.l,b.r);
    int y = min(a.r,b.l);
    return x>y||(x==y&&a.l>b.l);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        sum=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%s",b);
            int le=strlen(b);
            int l=0;
            int r=0;
            for(int j=0;j<le;j++)
            {
                if(b[j]=='(')l++;
                else
                {
                    if(l>0)
                    {
                        l--;
                        sum++;
                    }
                    else r++;
                }
            }
            G[i].l=l;G[i].r=r;
        }
        sort(G+1,G+1+n,cmp);
        int sum_l = 0;
        for(int i=1;i<n;i++)
        {
            //cout<<G[i].l<<" "<<G[i].r<<endl;
            sum+=min(G[i].l,G[i+1].r);
            int o =  G[i+1].r-min(G[i].l,G[i+1].r);
            sum+=min(o,sum_l);
            sum_l-=min(o,sum_l);
            sum_l = sum_l+ G[i].l-min(G[i].l,G[i+1].r);

        }
        printf("%lld\n",sum*2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a1046765624/article/details/81210681