【贪心】 Balanced Sequence HDU6299 2018多校第一场

Balanced Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4423    Accepted Submission(s): 1148


 

Problem Description

Chiaki has n strings s1,s2,…,sn consisting of '(' and ')'. A string of this type is said to be balanced:

+ if it is the empty string
+ if A and B are balanced, AB is balanced,
+ if A is balanced, (A) is balanced.

Chiaki can reorder the strings and then concatenate them get a new string t. Let f(t) be the length of the longest balanced subsequence (not necessary continuous) of t. Chiaki would like to know the maximum value of f(t) for all possible t.

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤105) -- the number of strings.
Each of the next n lines contains a string si (1≤|si|≤105) consisting of `(' and `)'.
It is guaranteed that the sum of all |si| does not exceeds 5×106.

 

Output

For each test case, output an integer denoting the answer.

扫描二维码关注公众号,回复: 2482038 查看本文章

 

Sample Input

2

1

)()(()(

2

)

)(

 

Sample Output

4

2

 

Source

2018 Multi-University Training Contest 1

#include <bits/stdc++.h>
using namespace std;

const int mn = 100010;

char ch[mn];
struct node
{
    int l, r;
    int cha;
} a[mn];
bool cmp(const node& a, const node& b)
{
    if (a.cha >= 0 && b.cha < 0)  /// 正贡献左括号,排前面
        return a.cha > b.cha;
    else if (a.cha < 0 && b.cha >= 0)  /// 否则倒置
        return 0;
    else if (a.cha >= 0 && b.cha >= 0)  /// 右括号少的在前
        return a.r < b.r;
    else if (a.cha < 0 && b.cha < 0)
        return a.l > b.l;
}
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        int n;
        scanf("%d", &n);
        int ans = 0;
        for (int i = 1; i <= n; i++)  // o(5 * 1e6)
        {
            scanf("%s", ch);

            stack<char> s;
            int len = strlen(ch);
            for (int j = 0; j < len; j++)
            {
                if (s.empty())
                {
                    s.push(ch[j]);
                    continue;
                }
                if (ch[j] == '(')
                    s.push(ch[j]);
                else if (ch[j] == ')')
                {
                    if (s.top() == '(')
                    {
                        s.pop();
                        ans += 2;
                    }
                    else
                        s.push(ch[j]);
                }
            }
            a[i].l = 0, a[i].r = 0;
            while (!s.empty())
            {
                if (s.top() == ')')
                    a[i].r++;
                else if(s.top() == '(')
                    a[i].l++;
                s.pop();
            }
            a[i].cha = a[i].l - a[i].r;
        }

        sort(a + 1, a + n + 1, cmp);

        stack<char> s;
        for (int i = 1; i <= n; i++)    // O(5 * 10e6)
        {
            for (int j = 1; j <= a[i].r; j++)
            {
                if (s.empty())
                {
                    s.push(')');
                    continue;
                }
                if (s.top() == '(')
                {
                    s.pop();
                    ans += 2;
                }
                else
                    s.push(')');
            }
            for (int j = 1; j <= a[i].l; j++)
            {
                s.push('(');
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/81226681