1106 Lowest Price in Supply Chain (25 分)

1106 Lowest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10^5), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i ID[1] ID[2] … ID[Ki]

where in the i-th line, K​i is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10
​10
​​ .

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2

题目大意:
给定一棵树的信息,根结点的货物的价格P,以及每向下一层价格的增长率%r,叶子结点代表零售商,要求所有零售价格中的最小值,以及能提供最低价格的零售商的个数

算法分析:
深度优先搜索的模板。保留遍历的最小层数minDepth,以及该层数下叶子结点的个数。DFS的参数为结点编号和层数,遍历到叶子结点时递归结束。注意剪枝

AC代码

扫描二维码关注公众号,回复: 12557962 查看本文章
#include<bits/stdc++.h>
using namespace std;
int nodeNum,cnt;
double originalPrice, minDepth = 999999999, riseRate;
//找minDepth而不是minPrice,最后再计算minPrice,可以减少计算量
vector<vector<int>> retailer;
void DFS(int index,int layer){
    
    
  if(layer>minDepth)
    return;//剪枝,如果当前层数已经大于最小层数,则本次遍历的price一定不是最小的,可以舍去
  if(retailer[index].size()==0){
    
    //当size为0时,表示index对应的结点代表零售商
    if(layer==minDepth)
      cnt++;
    else if(layer<minDepth){
    
    
      minDepth = layer;
      cnt = 1;
    }
  }
  for (int i = 0; i < retailer[index].size();i++)
    DFS(retailer[index][i], layer + 1);
}
int main(){
    
    
  cin >> nodeNum >> originalPrice >> riseRate;
  retailer.resize(nodeNum);
  riseRate = 1 + 0.01 * riseRate;
  int a, b;
  for (int i = 0; i < nodeNum;i++){
    
    
    cin >> a;
    if(a!=0){
    
    
      for (int j = 0; j < a;j++){
    
    
        cin >> b;
        retailer[i].push_back(b);
      }
    }
  }
  DFS(0, 0);
  printf("%.4lf %d", originalPrice*pow(riseRate,minDepth), cnt);
}

猜你喜欢

转载自blog.csdn.net/weixin_48954087/article/details/113852888