PAT Advanced1106 Lowest Price in Supply Chain(树,DFS)

版权声明:个人学习笔记记录 https://blog.csdn.net/Ratina/article/details/86591169

链接:PAT Advanced1106

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i ID[1] ID[2] … ID[K​i​​ ]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10​10​​ .

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2



题意:
给出一棵销售供应的树,树根唯一。在树根处货物的价格为P,然后从根结点开始每往子结点走一层,该层的货物价格将会在父亲结点的价格上增加r%。求叶子结点处能获得的最低价格以及能提供最低价格的叶子结点的个数。



以下代码:

#include<cstdio>
#include<vector>
#include<cmath>
#include<climits>
#include<algorithm>
using namespace std;
struct node
{
	vector<int> sub;  //记录子结点
}Node[100010];
int N,K,ID,cnt,min_d=INT_MAX;   //cnt记录数量,min_d代表最小深度
double P,r;
void DFS(int root,int depth)    //depth记录每次的深度
{
	if(Node[root].sub.empty())  //当该结点为叶子结点(其sub为空)
	{
		if(depth<min_d)         //当depth<min_d
		{
			min_d=depth;        //min_d更新
			cnt=1;              //cnt重新置为1
		}
		else if(depth==min_d)   //当depth==min_d
			cnt++;              //计数器cnt++
		return;
	}
	for(int i=0;i<Node[root].sub.size();i++)
	{
		int next=Node[root].sub[i];
		DFS(next,depth+1);
	}
}
int main()
{
	scanf("%d %lf %lf",&N,&P,&r);
	for(int i=0;i<N;i++)
	{
		scanf("%d",&K);
		while(K--)
		{
			scanf("%d",&ID);
			Node[i].sub.push_back(ID);
		}
	}
	DFS(0,0);   //DFS入口,记根结点深度为0
	printf("%.4f %d",P*pow(r*0.01+1,min_d),cnt);
	return 0;       //根据深度即可计算价格
}

猜你喜欢

转载自blog.csdn.net/Ratina/article/details/86591169