POJ 1659 Frogs' Neighborhood (Havel--Hakimi定理)

                  Frogs' Neighborhood
Time Limit: 5000MS   Memory Limit: 10000K
Total Submissions: 10545   Accepted: 4386   Special Judge

Description

未名湖附近共有N个大小湖泊L1L2, ..., Ln(其中包括未名湖),每个湖泊Li里住着一只青蛙Fi(1 ≤ i ≤ N)。如果湖泊LiLj之间有水路相连,则青蛙FiFj互称为邻居。现在已知每只青蛙的邻居数目x1x2, ..., xn,请你给出每两个湖泊之间的相连关系。

Input

第一行是测试数据的组数T(0 ≤ T ≤ 20)。每组数据包括两行,第一行是整数N(2 < N < 10),第二行是N个整数,x1x2,..., xn(0 ≤ xi ≤ N)。

Output

对输入的每组测试数据,如果不存在可能的相连关系,输出"NO"。否则输出"YES",并用N×N的矩阵表示湖泊间的相邻关系,即如果湖泊i与湖泊j之间有水路相连,则第i行的第j个数字为1,否则为0。每两个数字之间输出一个空格。如果存在多种可能,只需给出一种符合条件的情形。相邻两组测试数据之间输出一个空行。

Sample Input

3
7
4 3 1 5 4 2 1 
6
4 3 1 4 2 0 
6
2 3 1 1 2 1 

Sample Output

YES
0 1 0 1 1 0 1 
1 0 0 1 1 0 0 
0 0 0 1 0 0 0 
1 1 1 0 1 1 0 
1 1 0 1 0 1 0 
0 0 0 1 1 0 0 
1 0 0 0 0 0 0 

NO

YES
0 1 0 0 1 0 
1 0 0 1 1 0 
0 0 0 0 0 1 
0 1 0 0 0 0 
1 1 0 0 0 0 
0 0 1 0 0 0 

思路
http://www.cnblogs.com/wzjhoutai/p/6761606.html
这是一片不错的博客,详细介绍了Havel--Hakimi定理。
在执行删点的同时,把边连起来就行了.
代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int mp[15][15];

struct node
{
    int id;
    int num;
}a[15];

bool cmp(node x,node y)
{
    return x.num>y.num;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(mp,0,sizeof(mp));
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i].num);
            a[i].id=i+1;
        }
        int tt=n;
        int flag=0;
        for(int i=0;i<n;i++){
            sort(a,a+n,cmp);
            if(a[0].num<0){flag=1;break;}
            int t=a[0].num;a[0].num=0;
            for(int j=1;j<=t;j++){
                a[j].num--;if(a[j].num<0){flag=1;break;}
                mp[a[j].id][a[0].id]=mp[a[0].id][a[j].id]=1;
            }
            if(flag){break;}
            tt--;
        }
        if(flag==1){printf("NO\n\n");continue;}
        printf("YES\n");
        for(int i=1;i<=n;i++){
            for(int j=1;j<n;j++){
                printf("%d ",mp[i][j]);
            }
            printf("%d\n",mp[i][n]);
        }
        printf("\n");
    }
}
 

猜你喜欢

转载自www.cnblogs.com/ZGQblogs/p/9393620.html
今日推荐