6474: AtCoDeer and Rock-Paper(贪心)

6474: AtCoDeer and Rock-Paper

时间限制: 1 Sec   内存限制: 128 MB
提交: 143   解决: 89
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

AtCoDeer the deer and his friend TopCoDeer is playing a game. The game consists of N turns. In each turn, each player plays one of the two gestures, Rock and Paper, as in Rock-paper-scissors, under the following condition:
(※) After each turn, (the number of times the player has played Paper)≤(the number of times the player has played Rock).
Each player's score is calculated by (the number of turns where the player wins) − (the number of turns where the player loses), where the outcome of each turn is determined by the rules of Rock-paper-scissors.
(For those who are not familiar with Rock-paper-scissors: If one player plays Rock and the other plays Paper, the latter player will win and the former player will lose. If both players play the same gesture, the round is a tie and neither player will win nor lose.)
With his supernatural power, AtCoDeer was able to foresee the gesture that TopCoDeer will play in each of the N turns, before the game starts. Plan AtCoDeer's gesture in each turn to maximize AtCoDeer's score.
The gesture that TopCoDeer will play in each turn is given by a string s. If the i-th (1≤i≤N) character in s is g, TopCoDeer will play Rock in the i-th turn. Similarly, if the i-th (1≤i≤N) character of s in p, TopCoDeer will play Paper in the i-th turn.

Constraints
1≤N≤105
N=|s|
Each character in s is g or p.
The gestures represented by s satisfy the condition (※).

输入

The input is given from Standard Input in the following format:
s

输出

Print the AtCoDeer's maximum possible score.

样例输入

gpg

样例输出

0

提示

Playing the same gesture as the opponent in each turn results in the score of 0, which is the maximum possible score.

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
    char s[100005];
    scanf("%s", s);
    int sum=0, len=strlen(s), p=0, g=0;
    for(int i=0;i<len;i++)
    {
        if(s[i]=='g')
        {
            if(g>p)
            {
                sum++;
                p++;
            }
            else
                g++;
        }
        else
        {
            if(g>p)
                p++;
            else
            {
                sum--;
                g++;
            }
        }
    }
    printf("%d\n", sum);
    return 0;
} 
/**************************************************************
    Problem: 6474
    User: ldu_reserver201701
    Language: C++
    Result: 正确
    Time:0 ms
    Memory:1092 kb
****************************************************************/

猜你喜欢

转载自blog.csdn.net/qq_30796379/article/details/80498500