Find Small A HDU - 5980(移位取模水题)

Find Small A HDU - 5980

 As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits). 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai
≤2^32 - 1) follow
Output
Output one line,including an integer representing the number of ‘a’ in the group of given numbers.
Sample Input

3
97 24929 100

Sample Output

3

每次取模1<<8然后每次向左移八位

code:

#include <iostream>
#include <cstdio>
using namespace std;
int main(){
    int n,ans = 0;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        int x;
        scanf("%d",&x);
        while(x){
            if(x % (1<<8) == 97) ans++;
            x >>= 8;
        }
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81152048